Getting Started

When you first open Tracker it appears as shown below. Here's how to start analyzing a video:

  1. Open a video or tracker file.
  2. Identify the frames ("video clip") you wish to analyze.
  3. Calibrate the video scale.
  4. Set the reference frame origin and angle.
  5. Track objects of interest with the mouse.
  6. Plot and analyze the tracks.
  7. Save your work in a tracker file.
  8. Export track data to a spreadsheet.
  9. Print, save or copy/paste images for reports.

Note that the order of the buttons on the toolbar mirrors the steps used to analyze a video. For more information about Tracker's user interface, including user customization, see user interface.

1. Open a video or tracker file

Click the Open button or File|Open File menu item and select a digital video (mov, avi, mp4, flv, wmv, etc.), tracker data file (.trk), or zipped tracker file (.zip) to open. You can also open still and animated image files (.jpg, .gif, .png), numbered sequences of image files, and images pasted from the clipboard.

Play, scan or step through the video using the video player. For more information see videos.

Another option is to open the OSP Digital Library Browser by clicking the Open Library Browser button or choosing the File|Open Library Browser menu item. The library browser enables you to browse and access collections of digital library resources including videos and tracker files. For help using the OSP Digital Library Browser, choose its Help|Library Browser Help menu item.

2. Identify the frames ("video clip") you wish to analyze

Display the clip settings by clicking the Clip Settings button on the toolbar.

In the clip settings dialog, set the Start frame and End frame to define the range you wish to analyze. You can drag the player's slider to scan through the video and quickly find the frames of interest. If the video contains too many frames to analyze (more than 20 or so can become tedious), increase the Step size to automatically skip frames.

You can also set these video clip properties directly on the video player. For more information see video clips.

3. Calibrate the scale

Click the Calibration button and select the calibration stick.

Drag the ends of the calibration stick to a video feature with known length (for example, a meter stick). Then click the readout to select it and enter the known length (without units). For example, in the figures below the scale is set in meter units using a video image of a white PVC pipe with black stripes every 10 cm.

For more information see calibration stick, or for an alternate way to calibrate the video consider a calibration point pair.

4. Set the reference frame origin and angle

Click the Axes button to show the coordinate axes. Drag the origin and/or x-axis to set the reference frame origin and angle. A common choice for the origin is the initial position of an object of interest. For more information see axes, or for alternate ways to set the origin and/or angle consider a calibration point pair, an offset origin or the calibration stick.

The scale and reference frame origin and angle uniquely define the coordinate system used to convert pixel image positions to scaled world coordinates. In some videos the coordinate system properties may vary from one frame to the next (e.g., if the camera is zoomed the scale will change, or if panned the origin will change). Tracker makes it relatively easy to handle such videos--see coordinate system for more information.

5. Track objects of interest with the mouse or model them with particle models.

Click the Create button and choose a track type from the menu of choices. Most moving objects are tracked using a Point Mass track or modeled using a Dynamic Particle Model track.

When tracking an object, mark its position on every frame by holding down the shift key and clicking the mouse (crosshair cursor) as the video automatically steps through the video clip. Don't skip frames--if you do, velocities and accelerations cannot be determined.

Point mass tracks may also be marked automatically using autotracker.

You can always adjust a marked position by dragging it with the mouse or selecting it and nudging with the arrow keys. Right-click the video to zoom in for sub-pixel accuracy.

If modeling an object, enter values and expressions into the Model Builder as shown below. The particle will automatically draw itself on the video when played.

You can change the name and appearance of a track by clicking its button on the track control and choosing from the popup menu. Other toolbar buttons let you show or hide paths, trails, labels, velocity vectors and acceleration vectors.

For more information on tracks and the track control, see tracks. For detailed information on a specific track type, see point mass, center of mass, vector, vector sum, line profile, rgb region, particle model or two-body system.

6. Plot and analyze the tracks

The Plot View displays graphs of track data. Click the x- or y-axis label to change the variable plotted on that axis. To plot multiple graphs, click the Plots button and select the desired number. Right-click on a plot to access display and analysis options in a popup menu.

Two of the most powerful analysis options available from the popup menu are Define... and Analyze....

7. Save your work in a tracker (.trk) file

Click the Save button or File|Save As... menu item to save your work in an XML-based tracker file with the extension ".trk". When a saved tracker file is opened, Tracker loads the video, sets the clip and coordinate system properties, and rebuilds all tracks, custom variables and views. For more information see tracker files.

8. Export track data to a spreadsheet

Tracker's Datatable View displays track data in a table. To change the variables included in the table, click the Data button and select from the list displayed.

Data can be easily exported from the datatable by copying to the clipboard and pasting into a spreadsheet or other application. To copy, select the desired data in the table, then right-click and choose Copy Data from the popup menu. For more information see datatable view.

9. Print, save or copy/paste images for reports

You can print or copy an image of the entire Tracker frame or any individual view (e.g., a plot or datatable). To print the entire frame (all visible views), choose the File|Print... menu item. To print an individual view, right-click the view and choose Print... from the popup menu. To copy an image, choose the desired view from the Edit|Copy Image menu or right-click a view and choose Copy Image. Pasting printed or copied images into notes and reports is an excellent way to document your video analysis results.

To save an image, right-click on the view of interest and choose the Snapshot menu item. Then choose the File|Save Image menu item in the snapshot window.